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Startup 
When Vitesse is started, it will show the startup screen.   

 

From this screen, you can quickly start a new competition or open an existing one by clicking on the New 

Competition (1) or Open Competition (2) buttons.  The Recent Competitions list (3) will show up to the five most 

recently edited competitions.  You can quickly open one of those competitions by double clicking on its name. 
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Competition 
To create a new competition, click on the New Competition button on the start screen or select 

Competition>New from the main menu.  To open an existing competition, click on the start screen’s Open 

Competition button or select Competition>Open from the main menu.  Recently edited competitions can also 

be quickly opened by double clicking on their name in the start screen’s Recent Competitions list or by selecting 

them from the Competition>Recent list in the main menu. 

Once a competition has been created or loaded the competition setup screen will be displayed. 

 

Competition Info 
The Competition Info panel is used to enter the competition information. 

 

Field Description 

Name The competition’s name 

Starts The start date of the competition 

Ends The end date of the competition 



SpeedskatingResults.com Vitesse – Competition Manager User Guide 

Page | 6  
 

Track Location The competition location.  The drop-down list allows selection from 
SpeedskatingResults.com’s existing list of tracks.  For a location not in the list, 
select <other> and enter the location in the text box immediately below the list. 

Venue Optionally used to specify the competition venue’s name.  If a value is entered, it 
will be included in the start lists and other reports generated along with the 
location.  If left blank, only the location will appear in the reports. 

Seed Times Start The start date of the competition’s seed times range.  By default, it is set to the 
start of the current season. 

Seed Times End The end date of the competition’s seed times range.  By default, it is set to the end 
of the current season. 

ISU Times If checked, only times skated in an ISU sanctioned competition will be used as seed 
times.  If left unchecked, the seed times will be retrieved from any results. 

Tracks Allows definition of a filter to limit seed times to results skated only a certain 
tracks.  See the Track Filter section for information on configuring such filters. 

Group Method The default method to be used for generating the seed groups in the 
competition’s races.  See the Race Setup section for information on the available 
options. 

Pairs The default order for drawn pairs.  Pairs can be drawn either with slower skaters in 
the earlier pairs and faster skaters in the later pairs (Slow->Fast) or faster skaters 
in the earlier pairs and slower skaters in the later pairs (Fast->Slow).  See the Race 
Setup section for more information on pair ordering. 

 

 

The Competition Info panel can be minimized and expanded by clicking on the expander button (1) at the top 

left of the panel. 
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Track Filter 
By default, a skater’s best times skated within the specified date range, regardless of the track at which they 

were set, are retrieved from SpeedSkatingResults.com to be used as the seed times for races in the 

competition.  However, there may be cases where competition organizers wish to limit the tracks at which seed 

times can be skated (for example, exclude times skated in Calgary or Salt Lake City).  This may be accomplished 

by defining a track filter for the competition.  (A default track filter to be used for all new competitions created 

with Vitesse can also be defined.  See the Options/Track Filter section later in this document for more 

information.) 

 

To define a filter, click on the Tracks button (1) to open the Track Filter window. 

 

There are two methods for specifying a filter.  The Track Types section (1) allows tracks to be included or 

excluded as seed times sources based on characteristics of the location while the Tracks can be used to specify 

specific tracks to be included or excluded. 

Track Type Filter 

The following options are available for defining a Track Type filter. 

Option Description 

Indoor Fully enclosed tracks 

Outdoor Outdoor tracks 
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Covered Partially enclosed tracks 

High Altitude High altitude (1000m or higher) 

Low Altitude Low altitude (below 1000m) 

 

To exclude a track type, uncheck the option.  For example, to omit times from the high altitude indoor tracks 

(currently Calgary, Salt Lake City and Urumqi), uncheck the Indoor (3) and High Altitude (4) options 

 

Tracks 

As an alternative to defining the filter based on track type, the filter can be defined to only take, or to exclude, 

seed times from one or more specific tracks.  To add a track, click on the [+] button (5) or press the [Insert] key 

to add a new list entry.  Then select the track from the drop down list (6).  
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To take seed times only set at the specified track(s), choose Only (7) as the action.  The following filter would 

be to only use times set at Quebec City. 
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To exclude seed times from the specified track(s0, choose Exclude (8) as the action.  The following filter would 

exclude results from Calgary or Salt Lake City from being used as seed times. 

 

To remove a track from the list select it and click on the [-] button (9) or press the [Delete] key. 
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To save the filter, click on the Save button (10).  To exit without changing the filter, click on the Cancel button 

(11). 

When a track filter has been set for a competition, the Tracks button will be green (12).  When no filter is set 

the button is gray. 

 

Information on configuring a default Track Filter for competitions can be found in the Options section later is in 

this document. 

Races 
The Races panel is used to set up the competition’s races.   

Races List 
The left side of the Races panel shows all the races in the competition 
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To add a race, click on the add button (1).  To delete one or more races, select them in the list and click on the 

delete button (2) (or press the backspace or delete key).  To save the start lists for one or more races, select 

them in the list and click the start list button (3).  To edit a race, double click on its entry in the list.  Right 

clicking on the Races list will bring up a context menu that also allows access to these actions. 

Groups List 
A set of races may be collected in a group.  For example, it might be useful to collect all out of competition 

races in a group. 
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To create a race group, click on the add button (4).  The first group added will have the name “Group 1”, the 

second “Group 2”, etc.  To rename a group, simply click on its header in the list and enter the new name.  To 

add races to the group, select them in the races list and drag them to the group.  Races can also be dragged 

from one group to another.  A race can only be in one group at a time. 

To remove a race from a group select it and click on the delete button (5) (or press the delete or backspace 

keys).  This only removes the race from the group, it will still be present in the Races list.  To remove a group, 

click on its header and press the delete button (5) (or press the delete or backspace keys).  The group will be 

deleted, but not the races it contained. 

To save the start lists for one or more races in a group, select the races and click the start list button (6).  To 

save the start lists for all races in a group, select the group header and then click the start list button (6). 

Skaters 
The Skaters panel is used to select the participants in the competition. 
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The Skaters list on the left shows all skaters in the SpeedskatingResults.com database.  Click on the list and 

start typing a skater’s name to quickly search the list.  To add a skater to the competition double click on their 

list entry or select the entry and press the Enter key.   

Difficulties may be encountered when searching for skaters with names containing non-Roman characters or 

using a non-English keyboard.  If so, the search box (1) beneath the list may be used.  As a name is entered in 

the search box, the list will scroll to the best matching name.  While entering a name in the search box, the up 

(↑) and down (↓) arrow keys, Page Up and Page Down can be used to scroll through the list.  Pressing the 

Enter key will add the highlighted skater in the list to the competition. 

The list of skaters can be filtered by country (2) and gender (3) by using the controls beneath the list. 

Skater numbers are automatically assigned as skaters are added to the competition.  The start of the skater 

numbers range (4) can be set for both ladies and men.  If the range start number is changed after skaters have 

been added to the competition, all skaters of that gender will be renumbered automatically. 

Skaters may be imported into the competition from a list in another file.  To import skaters, click on the Import 

button (5).  See the Participants Import section later in this document for further details. 



SpeedskatingResults.com Vitesse – Competition Manager User Guide 

Page | 15  
 

 

After skaters have been selected for the competition, check the boxes in the race columns to add/remove 

skaters to/from a race.  The race date and distance is shown in each column header.  The headers for men’s 

races have a blue background, ladies’ a pink background and mixed a green background.  Skaters can also be 

added and removed from races through the race setup window described later in this document. 

The list of competitors can be searched either by skater number or name.  The black arrow in the competitors 

list header shows which column is being searched.  Click on the # (6) or Name (7) headers to switch between 

search modes.  As with the Skaters list, the search box (8) below the competitors may also be used.  The search 

will be for the selected column, # or Name, as indicated by the label to the left of the search box. 

The number of skaters in the competition is shown at the top of the competitors list (9). 

To add a skater that is not in the SpeedskatingResults.com database to the competition, click on the New 

Skater button (10) at the top right of the competitors list. 
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Enter the skater’s family and given names, select the skater’s country and enter the date of birth, if known.  

The skater’s race number is automatically set to the next available value.  However, it may be manually set to a 

different value if desired.  Since the skater is not in the SpeedskatingResults.com database, seed times can be 

manually specified. 

Click on Save to add the skater to the competition.   

If the skater is representing a country not in the available list, right click on the country list and then click on 

the New Country context menu item. 
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Enter the country’s three character IOC country code and its name.  Click on Save to add the country to the list 

of those available. 

Edit Skater Info 
A skater’s information can be edited after a skater has been added to the competition.  Double click on the 

skater in the competition participants list to show the edit window. 

 

The skater’s family name, given name, country, date of birth and race number can be modified.  Missing seed 

times can be added.  Incorrect seed times can be revised. 

Organization 
The Organization field (1) can be used to specify an organization to which a skater belongs (club, province, etc.)  

Organization names are limited to a maximum of 10 characters.  (Rather than manually entering the 

organization for each skater, the information can be read from a file when importing participants into the 

competition.  See the Participants Import section below for details.) 
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Clicking on the drop down list expander button (2) allows the organization to be selected from those already 

set for other skaters. 
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When organizations have been specified for skaters, the list of organizations and the skaters associated with 

each can be viewed by right clicking on the competitors list and selecting Organizations (1). 
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The organizations window will be displayed.  Click on the [+] (2) or [-] (3) button to the left of an organization’s 

name to display the skaters associated with the organization.  Double click on an organization’s name to edit its 

value (4) – any change will be applied to all skaters associated with the organization. 
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Participants Import 
As an alternative to manually selecting each participant for the competition, an existing list of skaters may be 

imported.  To open the import window, click the Import button above the participants list. 

Note: This section may make the import process seem more difficult than it (hopefully) is.  It is highly 

recommended to actually try the import process, experimenting with the different options while referring to 

this document as necessary. 

 

The Import Skaters list (1) on the left will show the skaters being imported and their match, if any, to skaters in 

the SpeedskatingResults.com database.  The Skaters list (2) on the right shows all skaters from the 

SpeedskatingResults.com database.  While initially the list will show only Ladies or Men depending upon 

whether the Import button above the Ladies’ or Men’s participants list was clicked, that may be changed by 

selecting a different value from the filter (3).  Selecting all will allow both ladies and men to be imported at the 

same time.  

The default import format expects skater information to be in three columns, similar to the following 

spreadsheet. 
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The first column contains the skater’s complete name, the second their country (IOC country codes for best 

results), and the third their age class or date of birth. 

Other import formats can be selected and defined via the import format list (4).  If the names are in a single 

column, the Family Name First check box can be used to specify the order of family and given names.   

The list of skaters can be either cut and pasted from another application (e.g. a spreadsheet) or read directly 

from a file.  If using cut and paste, press Ctrl-V to paste the list of skaters.  Alternatively, right click on the 

Import Skaters list to bring up the menu allowing the skaters to either be pasted or loaded from a file. 
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Once the skater list has been imported, Vitesse will try to match each skater to an entry in the 

SpeedskatingResults.com database.   
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The skater’s name, country and age class or date of birth will be used to find the best match.  Skaters for which 

a successful match is found will be colored pink (Ladies) or blue (men).   

When multiple SpeedskatingResults.com database entries match a skater, Vitesse will use the skater’s country 

and age class/date of birth in attempt to find the correct match.  If a best match can be determined, the row 

will be colored pink (Ladies) or blue (men) (1).  If Vitesse was unable to determine a best match from the 

available options, the row will be colored green (2).   

If Vitesse is unable to find any match at all, the row will remain gray and the matching skater columns will be 

empty. 

The Skaters list on the right shows all skaters from the SpeedskatingResults.com database.  As with other lists, 

the Skaters list can be searched by typing a name while in the list or by using the search box below it.  Pressing 

[Enter] or double-clicking on a skater in the Skaters list will set that skater as the match for the highlighted 

entry in the Import Skaters list on the left.  Skaters may also be dragged and dropped on any entry in the 

Import Skaters list. 

To clear a match, select the row in the Import Skaters list and press [Delete]. 

When multiple matches are found, clicking on the […] button will bring up a list of all potential matches. 
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Double click on one of the potential matches to select it.  Press [ESC] to close the list without making a 

selection.   
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To add all successfully matched skaters to the competition, click the Set as Participants button (1).  To delete 

the imported list, click the Clear button (2).  (To clear all matches without deleting the import list, hold [Ctrl] 

while clicking the Clear button.)  To have Vitesse make another attempt to match any unmatched skaters, click 

the Match button (3).  Use the navigation buttons (< and >) (4) to move between unmatched skaters in the 

Import Skaters list. 

To close the Import Participants window click either the OK or Cancel buttons.  The OK button (5) will add any 

matched skaters in the Import Skaters list to the competition before closing the window.  The Cancel button (6) 

will close the window without adding any skaters. 

Import Formats 
If skaters need to be imported from a list that does not match the default format, additional formats can be 

defined. 
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To define or modify the import formats, right click on the format selector (1) and then click Edit to display the 

format editor. 
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Click the + button (1) to add a new format.  Click the – button (2) to delete a format.  Select a format and right 

click to bring up a context menu allowing a copy of the format to be made.  The default format may not be 

modified or deleted. 
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Each format must have a unique name (1).   

The Column Separator (2) allows the separator between columns to be specified.  If cutting and pasting from a 

spreadsheet, select Tab.  Semicolons (;) and commas (,) may also be used as separators.  If the source uses 

some other character to delimit columns, select Other and enter the separator character in the box to the right. 

If comment lines are present in the imported data, enter the character(s) used to indicate a comment in the 

Comment Lines field (3).  Any line in the imported data that starts with one of the characters will be ignored. 

Finally, define the columns (4) in the imported data.  Each column may be given one of following values: 

Column Type Description 

Name Column containing the skater’s full name (family and given). 

Family Name Column containing the skater’s family name 

Given Name Column containing the skater’s given name 

Country Column containing the skater’s country.  IOC country codes provide the best results 
when matching skaters 

Age Class Column containing the skater’s age class or date of birth. 

Number Column containing the skater’s number for the competition.  See the Skater 
Numbers section below for more information. 

Organization Column containing the organization (club, province, etc.) to which the skater 
belongs. 

Ignore Column should be ignored 
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Columns only need to be specified up to the last one containing information to be used in the matching process 

during the import.  If there are more columns than those defined, the remaining columns will be treated as 

Ignore columns. 

The Example format definition shown above would correspond to the following spreadsheet. 
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When multiple import formats have been defined, switch between them using the format selector above the 

Import Skaters list. 

Skater Numbers 
If a Number column is specified in the import format, the value in that column will be assigned as the skater’s 

number for the competition.   Whatever value is specified in the column will be assigned to the skater, even if 

the value is outside the range specified in the main window’s Skaters list 

Duplicate Numbers 

If the same number is specified for multiple skaters, Vitesse will automatically resolve the conflict.  In the 

following import, the number 3 is assigned to two different skaters. 
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To resolve the conflict, Vitesse will assign the requested number, 3, to the first skater appearing in the import 

(highlighted in green).  The second skater, highlighted in red, will be assigned the next available number, 5. 

The Duplicate Skater Numbers window can be shown again later by right clicking on the Skaters list in the main 

window and selecting Duplicate Numbers from the context menu. 

 

 

Native Language Alphabets 
By default, Vitesse shows skater’s names using the Roman alphabet.  For countries using a different alphabet 

(for example the Cyrillic alphabet for Russia), Vitesse may be configured to use that alphabet instead.  See the 

Options – Names in Native Language Alphabets section later in this document for details on how to do so. 

 

SpeedskatingResults.com Connection 
The status of the network connection to SpeedskatingResults.com is shown by the button the bottom left of 

the main menu.  When the connection is active the status will show as connected. 

 

If the connection is not active, the status will show as disconnected.  While disconnected Vitesse will not be 

able to retrieve skater information and seed times from SpeedskatingResults.com. 

 

To toggle the connection state, click on the connection button. 
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Once the competition’s skater information and seed times have been retrieved from SpeedskatingResults.com, 

Vitesse can operate in disconnected mode.  It will use the skater information and seed times that have been 

saved to the competition’s file.  However, it is highly recommended to return to connected mode before 

generating the seed groups and start lists for a race to ensure that any updated seed times are retrieved from 

SpeedskatingResults.com. 
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Race Setup 

New Race 
When a new race is added, the initial setup window will be shown. 

 

Field Description 

Distance The race distance.   

Type The race type:  Ladies, Men or Mixed 

Description Any additional information to be included in the race name 

Date The race date 

 

The race distance drop-down list provides predefined distances of 100, 300, 500, 700, 1000, 1500, 3000, 5000 

and 10000 meters.  To add a race of any other distance, select <other> from the drop-down list and then enter 

the distance in the text box (1) that will appear to the right of the list.   

 

The SpeedskatingResults.com database only tracks results for the predefined distances.  If another distance is 

specified, it will not be possible to retrieve seed time values from SpeedskatingResults.com. 

Once a race has been added, the full race editor window (described in the next section) will be shown the next 

time the race is selected from the main window’s races list.  To immediately switch to the full editor, click on 

the expand button (2) at the bottom left of the window. 
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Editing a Race 
Once a race has been created, the race editor can be viewed by double clicking on the race from the main 

window’s races list. 

 

The fields at the top of the window allow the information specified when the race was originally added to be 

modified. 

Field Description 

Distance The race distance.   

Type The race type:  Ladies, Men or Mixed 

Description Any additional information to be included in the race name 

Date The race date 

 

Race Participants 
The Participants panel is used to specify the skaters entered in the race.  The Competition Participants list on 

the left side shows all the skaters entered in the competition.  The Race Participants list on the right shows the 

skaters entered in the race.  Skaters can be added to the race by dragging them from the Competition 

Participants list or by selecting them in that list and double-clicking or pressing the Enter Key.  Any skaters 

added to the race from the main window’s Skaters panel will already be present in the list 

To remove a skater from the race, select their entry in the Race Participants list and press the Delete or 

Backspace keys. 
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To search the Competition Participants list for a skater, click on the list and then start typing the skater’s 

number or name.  Switch between search modes by clicking on the # or Name header fields at the top of the 

list.  A small black arrow will show which field is currently being searched. 

The search box below the Competition Participants list can also be used to search for a skater (especially useful 

when searching for skaters with non-English characters in their names).  Which column, # or Name, is being 

searched will be shown by the label to the left of the search box.  While entering a name in the search box, the 

up (↑) and down (↓) arrow keys, Page Up and Page Down can be used to scroll through the list.  Pressing the 

Enter key will add the highlighted skater in the list to the race. 

Skaters may be imported into the race from a list in another file.  To import skaters, click on the Import button 

(1).  See the Race Participants Import section later in this document for further details. 

 

Pairs 
The Pairs panel is used to create the seed groups and start list for a race. 

 

On this panel the Race Participants list is on the left and shows all skaters entered in the race.  In the center is 

the seed Groups list.  On the right is the Pairs list. 

Seed Groups 

Seed groups can be created manually by clicking on the add button (1) below the list.  Skaters can then be 

manually dragged from the Race Participants list to the desired seed group.   
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Groups can be renamed by clicking on their header and typing a new name.  To remove a group, select its 

header and click on the delete button (2) below the list. 

One of the primary purposes of the Vitesse Competition Manager is the automatic creation of seed groups 

based on times retrieved from SpeedskatingResults.com.  Any one of four different methods for creating the 

seed groups can be selected via the controls (3) above the list. 

Method Description 

Size Groups of the size specified will be created.  Any skaters without a seed time will 
be placed in a single group at the start of the list.  If there are not enough skaters 
to completely fill each group to the size specified, the first group of seeded skaters 
will be smaller than the size requested.   

Count The specified number of groups will be created.  If there are an odd number of 
skaters entered in the race, the first group will be of an odd numbered size.  The 
seed groups will be kept as close in size as possible.  If there are not enough 
skaters to make the groups of equal size, the earlier groups of slower skaters will 
be of slightly larger size. 

Single All skaters will be placed in a single seed group 

Ladies/Men Two groups will be created, one for ladies and the other for men. 
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The above illustration shows the automatic creation of seed groups of size 6.  Notice how the skaters without 

seed times are in the first group and how the second group, with the slowest seeded skaters, is of a size smaller 

than 6. 

 

 

The above illustration shows the automatic creation of 3 seed groups.  Notice how the first group contains six 

skaters while groups 2 and 3 contain four each. 

When automatically creating seed groups using the Size or Count methods, if at the transition between two 

seed groups there are two or more skaters with the same seed time, which of those skaters goes in the prior 

seed group and which in the next will be determined by a random selection. 
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Pairs 

 

Pairs can be manually added and removed by clicking the add (1) and remove (2) button below the Pairs list.  

Skaters can then be dragged from the Race Participants or Groups list to the pairs. 

The automatic creation of the pairs for the start list is another major feature of Vitesse.  Once the seed groups 

have been created, the pairs can then be drawn using one of three methods using the controls (3) above the 

list. 

Method Description 

Random The pairs are filled by randomly drawing skaters from the seed groups.  The 
skaters in the earlier seed groups, the slower skaters, will be placed in the earlier 
pairs.  The skaters from the fastest seed group will be placed in the later pairs.  
This method works best when the seed groups were created using the Size or 
Count methods. 

Seed Time The skaters are placed in pairs based strictly on their seed times.  The slowest 
skaters in the earlier pairs, the fastest in the later pairs.  Within a pair the skater 
with the fastest seed time will be placed in the inside lane and the skater with the 
slower time in the outside lane.  There is no random element to this draw method 
and it works best when the seed groups were created using the Single or 
Lades/Men methods. 
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Seed Time – Random 
Lane 

This method is identical to Seed Time except that for each pair a random draw is 
made to determine which skater is placed in the inside lane and which in the 
outside. 

 

If Fill Pairs (4) is checked and there are an odd number of skaters in a seed group, the last drawn skater from 

the previous seed group will be promoted to the following seed group and placed in the inside lane of the first 

pair for that group. 

Pairs can be created with slower skaters in the earlier pairs and faster in the later pairs, or vice versa.  This 

ordering of the pairs can be changed using the pairs order button (5).  The order can be set, and changed, 

before or after the pairs are created. 

Once the pairs have been created, they may be manually changed.  Skaters can be dragged from one pair to 

another.  Skaters can be removed from a pair by clicking on the skater and pressing the Delete or Backspace 

key or by clicking on the delete button (2) below the list.  To delete an entire pair, click on the pair number and 

then press Delete or Backspace, or click on the delete button (2). 

If a deletion has left an empty spot in a pair, skaters from preceding or following pairs can be shifted down or 

up to fill in the pair.  Select the skaters to be shifted by holding down the Shift key while clicking on the first and 

last skaters in the range.  Then press Ctrl-↓ to shift the skaters down or Ctrl-↑ to shift the skaters up one pair.  

Skaters can only be shifted up or down when there is an empty spot in the following or preceding pair. 

To create quartets, click on the pair number of the first pair to be skated in quartets then hold down the Shift 

key and click on the pair number of the final pair to be skated in the quartets.  Press Ctrl-Q to toggle whether 

the pairs are skated as quartets.  When quartets have been selected, the backgrounds of the skaters will 

change to show the presence of a quartet.  Instead of the white inner lane background and red outer lane 

background of a single pair, the first pair in a quartet will have a silver inner lane background and darker red 

outer lane background.  The second pair in a quartet will have a yellow inner lane background and a blue outer 

lane background. 

A context menu with the various actions that can be taken with the Pairs List can be displayed by right clicking 

on the list. 

Once the pairs have been created, the start list can be immediately saved by clicking on the button (6) above 

the pairs list.  Start lists can also be saved from the main window’s Races list as well as via the File>Start Lists 

item in the main menu. 

Revisions 

If the pairs are modified after having been saved, a Revised time stamp (1) will be shown (and included in saved 

pairs PDFs or Excel spreadsheets).  To remove the revised time stamp, uncheck the box to the left of it. 
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Larger Text 
A large text option is available for a number of the panels in the race editor window.  The larger text can make 

the lists easier to read when the Vitesse windows are projected on a large screen during a public draw. 
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The text in the Race Participants list can be enlarged by clicking on the Large Text button (1) at the top right of 

the Race Participants list.  Click the button a second time to restore the normal text size.  The Race Participants 

list can be made wider by dragging the separator bar (2) between it and the Competition Participants list. 
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The large text option is also available for the Groups and Pairs lists.  The large text button (1) at the top right of 

both lists is used to toggle between large and normal text.  The Groups and Pairs lists can be made wider or 

narrower by dragging the separator bars (2) between them. 

For even better legibility, a separate window can be opened containing only the Groups and Pairs lists.  The 

window is opened by clicking on the Groups (3) or Pairs (4) label at the top left of the lists. 
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The full window Groups list works identically to that in the race editor window.  To switch to the pairs list, click 

on the Pairs tab (1) at the top left. 
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The full window Pairs list works identically to that in the race editor window.  To switch back to the Groups list, 

click on the Groups tab (1) at the top left. 

Race Participants Import 
As an alternative to manually selecting skaters, participants for a race may be cut and pasted or read from a 

file.  Click on the Import button above the Competition Participants list to open the import window.  Race 

participants import works almost identically, using the same import formats, as described in the competition 

Participants Import section earlier in this document.  The list of skaters in the Skaters column on the right will 

be limited to those competition participants valid for the race type. 

If the Race Number column is specified in the import format, the value in that column will be used to find the 

skater by their assigned number.  No check will be made using the skater’s name or other information. 
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Mass Start Setup 
To add a mass start race, either right click on the Races list in the main window and select Add->Mass Start or 

right click on the Add [+] button below the list and select Mass Start… 
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New Race 
When a new mass start race is added, the initial setup window will be shown. 

 

Field Description 

Distance The race distance.   

Type The race type:  Ladies, Men or Mixed 

Description Any additional information to be included in the race name 

Date The race date 

Seed Distance The race distance to use for seed times 

 

Once a race has been added, the full race editor window (described in the next section) will be shown the next 

time the race is selected from the main window’s races list.  To immediately switch to the full editor, click on 

the expand button (1) at the bottom left of the window. 

 

Editing a Race 
Once a mass start race has been created, the race editor can be viewed by double clicking on the race from the 

main window’s races list. 
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The fields at the top of the window allow the information specified when the race was originally added to be 

modified. 

Field Description 

Distance The race distance.   

Type The race type:  Ladies, Men or Mixed 

Description Any additional information to be included in the race name 

Date The race date 

Seed Distance The race distance to use for seed times 

 

Race Participants 
The Participants panel is used to specify the skaters entered in the race.  The Competition Participants list on 

the left side shows all the skaters entered in the competition.  The Race Participants list on the right shows the 

skaters entered in the race.  Skaters can be added to the race by dragging them from the Competition 

Participants list or by selecting them in that list and double-clicking or pressing the Enter Key.  Any skaters 

added to the race from the main window’s Skaters panel will already be present in the list 

To remove a skater from the race, select their entry in the Race Participants list and press the Delete or 

Backspace keys. 

To search the Competition Participants list for a skater, click on the list and then start typing the skater’s 

number or name.  Switch between search modes by clicking on the # or Name header fields at the top of the 

list.  A small black arrow will show which field is currently being searched. 

The search box below the Competition Participants list can also be used to search for a skater (especially useful 

when searching for skaters with non-English characters in their names).  Which column, # or Name, is being 
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searched will be shown by the label to the left of the search box.  While entering a name in the search box, the 

up (↑) and down (↓) arrow keys, Page Up and Page Down can be used to scroll through the list.  Pressing the 

Enter key will add the highlighted skater in the list to the race. 

Skaters may be imported into the race from a list in another file.  To import skaters, click on the Import button 

(1).  See the Race Participants Import section earlier in this document for further details. 

 

Start List 
The Start List panel is used to create the start list for the race. 

 

On this panel the Race Participants list is on the left and shows all skaters entered in the race.  On the right is 

the Start List. 

The start list can be automatically created using the controls (1) above the list.  Two draw methods are 

available for creating the start list. 

Method Description 

Seed Time The skaters are placed into starting positions based on their seed time from the 
specified distance.  The skater with the fastest seed time is placed in the first 
position.  Skaters with no seed time will be placed in the final start positions.  If 
two or more skaters have the same seed time, their positions will be randomly 
drawn. 

Random The start list filled by randomly drawing skaters from the seed groups.   
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The First Helmet # field is used to specify the helmet number assigned to the skater drawn for the first start 

position.  All subsequently drawn skaters are assigned the next available helmet number. 

The start list can be created manually as well.  Dragging a skater from the Race Participants to the Start List will 

add a new start position and place the skater in it.  Skaters can also be dragged and dropped into existing start 

positions.  Starting positions can be added (3) and removed (4) from the start list using the buttons below the 

list. 

Once the start list has been created, it may be manually changed.  Skaters can be dragged from one position to 

another.  Skaters can be removed from the start list by clicking on the skater and pressing the Delete or 

Backspace key or by clicking on the delete button (3) below the list.  To delete a start position, click on the 

position number and then press Delete or Backspace, or click on the delete button (4). 

If a deletion has left an empty spot in the start list, skaters from preceding or following positions can be shifted 

down or up.  Select the skaters to be shifted by holding down the Shift key while clicking on the first and last 

skaters in the range.  Then press Ctrl-↓ to shift the skaters down or Ctrl-↑ to shift the skaters up one position.  

Skaters can only be shifted up or down when the preceding or following position is empty. 

A context menu with the various actions that can be taken with the Start List can be displayed by right clicking 

on the list. 

Once the start list has been created, it can be immediately saved by clicking on the button (5) above the list.  

Start lists can also be saved from the main window’s Races list as well as via the File>Start Lists item in the main 

menu. 
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Team Pursuit/Sprint Setup 
To add a team pursuit or team sprint race, either right click on the Races list in the main window and select 

Add->Team Pursuit/Sprint or right click on the Add [+] button below the list and select Team Pursuit/Sprint… 
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New Race 
When a new team pursuit/sprint race is added, the initial setup window will be shown. 

 

Field Description 

Distance The race distance and whether it is a team pursuit or team sprint 

Type The race type: Ladies, Men or Mixed 

Description Any additional information to be included in the race name 

Date The race date 

 

Once a race has been added, the full race editor window (described in the next section) will be shown the next 

time the race is selected from the main window’s races list.  To immediately switch to the full editor, click on 

the expand button (1) at the bottom left of the window. 

Editing a Race 
Once a team pursuit/sprint race has been created, the race editor can be viewed by double clicking on the race 

from the main window’s Races list. 
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The fields at the top of the window allow the information specified when the race was originally added to be 

modified. 

Field Description 

Distance The race distance and whether it is a team pursuit or team sprint 

Type The race type: Ladies, Men or Mixed 

Description Any additional information to be included in the race name 

Date The race date 

 

Race Participants 
The Participants panel is used to specify the skaters entered in the race.  The Competition Participants list on 

the left side shows all the skaters entered in the competition.  The Race Participants list on the right shows the 

skaters entered in the race.  Skaters can be added to the race by dragging them from the Competition 

Participants list or by selecting them in that list and double-clicking or pressing the Enter Key.  Any skaters 

added to the race from the main window’s Skaters panel will already be present in the list 

To remove a skater from the race, select their entry in the Race Participants list and press the Delete or 

Backspace keys. 

To search the Competition Participants list for a skater, click on the list and then start typing the skater’s 

number or name.  Switch between search modes by clicking on the # or Name header fields at the top of the 

list.  A small black arrow will show which field is currently being searched. 

The search box below the Competition Participants list can also be used to search for a skater (especially useful 

when searching for skaters with non-English characters in their names).  Which column, # or Name, is being 

searched will be shown by the label to the left of the search box.  While entering a name in the search box, the 
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up (↑) and down (↓) arrow keys, Page Up and Page Down can be used to scroll through the list.  Pressing the 

Enter key will add the highlighted skater in the list to the race. 

Skaters may be imported into the race from a list in another file.  To import skaters, click on the Import button 

(1).  See the Race Participants Import section earlier in this document for further details. 

Teams 
Teams must first be created before making the race’s start list. 

 

The First Team # field (1) specifies the number to be assigned to the first created team.  Subsequently added 

teams will be assigned the next available number.  If the First Team # is later changed, all teams will be 

renumbered. 

Teams are added by clicking on the add (2) button below the list.  To remove a team, select it and click on the 

delete button (3). 

To add skaters to a team, drag the skater from the Race Participants list at the left to the desired spot on a 

team. 
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When a team is first added, it is given a name based on its team number.  Vitesse allows teams to be 

automatically renamed based on the nationality of the skaters on the team.  To rename the teams, right click 

on the list and select Name by Country from the menu. 
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If all racers on the team represent the same nation, the team will be given that country’s name (e.g. United 

States).  If the team contains skaters from multiple countries, the name will be the combination of the IOC 

country codes for the skaters on the team (e.g. COL-USA).  If multiple teams would have the same name, a 

number is added at the end to make the names unique (e.g. United States 1, United States 2). 

To return to using names based on the team number, right click on the list and select Name by Number from 

the menu.  This option can also be used to rename teams if their numbers have been changed. 

Team names can be manually modified.  To change a name, double click on it and enter the new value. 
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Team numbers can be changed in a similar manner.  Double click on the number and enter the new value.  

Vitesse will not allow the same number to be assigned to multiple teams in a race. 
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To return to using team names based on the team number, right click on the list and select Name by Number 

from the menu.  This option also may be useful if teams have been renumbered, as the team name will not 

automatically be updated at that time. 
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Pairs 
Once the teams have been defined, the start list may be created. 

 

Clicking on the Draw button (1) will randomly generate the pairs.  Pairs can also be manually created and 

rearranged.  Dragging a team from the Teams list to the blank area of the Pairs list will add a new pair to the 

end of the list containing that team.  Pairs may also be added using the add (3) button below the list.  Teams 

may be dragged from the Teams list to any pair.  Teams may also be dragged from one position in the Pairs list 

to another.  To remove a team from the pairs, click on the team and press the Delete or Backspace key or click 

on the delete button (4).  To remove an entire pair from the list, click on the pair number to select the pair, 

then press the Delete or Backspace key or click on the delete button (4). 

If a deletion has left an empty spot in a pair, teams from preceding or following pairs can be shifted down or up 

to fill in the pair.  Select the teams to be shifted by holding down the Shift key while clicking on the first and last 

teams in the range.  Then press Ctrl-↓ to shift the skaters down or Ctrl-↑ to shift the skaters up one pair.  

Teams can only be shifted up or down when there is an empty spot in the following or preceding pair. 

A context menu with the various actions that can be taken with the Pairs list can be displayed by right clicking 

on the list. 

Once the pairs have been created, the start list can be immediately saved by clicking on the button (6) above 

the pairs list.  Start lists can also be saved from the main window’s Races list as well as via the File>Start Lists 

item in the main menu. 
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Files 

Participants List 
The list of participants in the competition and each race can be saved by selecting File>Participants from the 

main menu.  The file save dialog will be displayed.   

 

The default name for the participants list file can be changed by editing the File name (1).  The participants list 

can be saved as either a PDF file or Excel spreadsheet by selecting the Save as type value (2). 

Once saved the first pages in the participants list file will have the lists of all the skaters (ladies and men) in the 

competition.  The following pages will show the skaters entered in each individual race along with their seed 

time for the race.  In the Excel spreadsheet addition information about where and when the seed time was 

skated will be included. 

Start Lists 
Start lists can be saved by selecting File>Start Lists from the main menu.  A dialog will then be displayed 

allowing the selection of which races’ start lists are to be saved. 
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To include a race’s start list in the saved file, check the box next to the race (1).  Uncheck the box for races 

whose start lists should not be saved. 

The Ladies/Men/Mixed filter buttons (2) beneath the races list will quickly select only the races of the specified 

type.  The All or None buttons (3) will select or clear all the races in the list.   

If race groups have been defined, a group’s races can be selected by choosing the group in the drop-down list 

and clicking the select button (4).  Select the <none> option from the drop-down list to choose all races that are 

not part of a race group. 

If the competition spans multiple days, all the races for a single day can be selected by choosing the date in the 

drop down and clicking the select button (5). 

Once the desired races have been selected, click the Save button.  In addition to selecting races via the 

File>Start Lists menu item, one or more races can be selected in the main window’s Races panel and the save 

start list button  clicked.  The save dialog will immediately be displayed.  A single race’s start list can also be 

immediately saved from its race setup window.  No matter which means of selecting races is used, the file save 

dialog will then be displayed. 
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The default name for the start lists file can be changed by editing the File name (1).  The start lists can be saved 

as either a PDF file or Excel spreadsheet by selecting the Save as type value (2). 

 

Seed Times Table 
The seed times table is an Excel spreadsheet similar to that generated by the older Participants List app.  The 

first two pages of the spreadsheet are summary pages showing all women and men participating in the 

competition along with their seed times for all distances selected when the file is saved.  The remaining 

spreadsheet pages show detailed information for each skater’s seed time for a specific distance.  This 

information is similar to that in the Participants List file, however each individual distance page shows the seed 

times for all skaters in the competition, not just those entered into a specific race. 

To save a seed times table spreadsheet, select File>Seed Times Table from the main menu.  Which distances 

should be included in the spreadsheet can then be selected. 
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By default, the distances selected for women and men will be the same as the competition’s race distances.  

However, additional distances may be selected, or deselected.  Click Save to save the spreadsheet, at which 

time a file save dialog will be displayed allowing the save file name and location to be specified. 

 

Personal Records / Season Bests 
The Personal Records or Season Bests for all skaters in the competition can be saved as either a PDF file or 

Excel spreadsheet by selecting File>Skater Info>PRs or File>Skater Info>SBs. 

 

File Options 
The paper size and whether to use color can be specified for PDF files.  Whether a skater’s organization will be 

shown can also be specified for both PDFs and Excel spreadsheets.  To change these options, refer to the PDF 

Options section below. 
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Options 
To modify Vitesse’s configurable options, select Options>Modify from the main menu. 

PDF Options 
The PDFs page of the options window shows the formatting options used when saving PDF files. 

 

 

Option Description 

Paper Size The paper size for the PDF files.  Either A4 or Letter can be selected.  

Use Color Should the PDF file include color elements?  Mainly backgrounds for the lanes in 
the start lists.  Uncheck to save the PDF in black and white. 

Show Organizations Should organizations (club, province, etc.) be shown in the PDF files?  This option 
also applies to Excel spreadsheets.   

 

Track Filter 
The Track Filter page of the options windows allows a default seed times track filter to be defined.  The default 

track filter will be used when a new competition is created. 
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See the Competition/Track Filter section earlier in this document for a description of the options available 

when defining a track filter. 

Languages (Beta) 
Vitesse provides some support for languages other than English.  The Languages page of the options window 

can be used to modify the language settings. 
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Switch to one of the available languages by selecting it from the list (1).  Vitesse has built-in language 

translations for English, Français (French), Polski (Polish), Norsk (Norwegian), Русский (Russian) and Svenska 

(Swedish).  A language’s translations can be modified by clicking on the edit button (2) to open the translations 

window.  A new language can be added by clicking on the add [+] button (3) to open the translations window. 

Editing Translations 
Any of a language’s translated terms can be modified in the translations window. 

 

Any changed translations will be highlighted in yellow.  Hover the mouse pointer over the term names in the 

left column to show a tip window with a description of the term and any length limitations.  
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If editing translations for one of the languages built-in to Vitesse, restore the default translations by clicking on 

the Reset to Defaults button (1).  Save any modifications by clicking the Save button (2).  Exit and discard any 

changes by clicking on the Cancel button (3). 

Edited translations can be exported and imported by other users running Vitesse.  See the Export and Import 

Options section later in this document for details. 

 

Adding a Language 
When adding a language, first give it a unique name (1).  Once a new language has been saved, the name 

cannot be changed at a later date. 

 

Then provide translations for the terms listed.  Hover the mouse pointer over the term names in the left 

column to show a tip window with a description of the term and any length limitations.  Translations can be left 

blank – if so, the default English language term will be used. 
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Save the new language by clicking the Save button (2).  Note that once saved the language’s name cannot be 

changed.  Exit and discard the new language translations by clicking on the Cancel button (3). 

A user-defined language can be later modified, see the Editing Translations section above. 

The new language translations can be exported and imported by other users running Vitesse.  See the Export 

and Import Options section later in this document for details. 

Deleting a Language 
To delete a user-defined language, edit it in the translations window.  The click on the Delete button (1) in the 

lower left corner.  Only user-defined languages can be deleted.  Languages built into Vitesse can only be reset 

to their defaults (see the Editing Translations section above). 
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Important Notes 
1. Non-English language support is currently a Beta feature of Vitesse.  PDF and Excel spreadsheets will 

use the translated terms.  However much of the application’s user interface will still be shown in 

English. 

2. When the language is changed, or when one or more term translations are modified, it is highly 

recommended that Vitesse be closed and restarted to ensure that all language changes take effect. 

3. If you add a new Language, please export the Vitesse options (see the Export and Import Options 

section later in this document) and send the file to SpeedskatingResults.com (ovalstats@q.com) so that 

the new language can be included as a built-in language in a future Vitesse release. 

4. Please send any translation errors or improvement suggestions to SpeedskatingResults.com 

(ovalstats@q.com). 

 

Names in Native Language Alphabets 
By default, Vitesse shows skater’s names using the Roman alphabet.  For countries using a different alphabet 

(for example the Cyrillic alphabet for Russia), Vitesse may be configured to use names in that alphabet instead.  

To do so, check one or more countries in the Names – Native Alphabet list. 

 

For the countries selected, names in the native alphabet will then be shown by Vitesse. 

mailto:ovalstats@q.com
mailto:ovalstats@q.com
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For names to be displayed using the native alphabet, that information must be available in the 

SpeedskatingResults.com database.  If a skater’s name in the native alphabet is not available from 

SpeedskatingResults.com, the name will be shown using the Roman alphabet. 

Export and Import Options 
The language, translations, and native language alphabet options can be exported and imported into Vitesse 

running on a different computer. 
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To export the options, select Options>Export (1) from the main menu.  A save file dialog will be shown to let 

you choose the location in which to save the file, changing the name if you wish (the default is 

vitesse_options.json) 

To import the option settings into Vitesse, select Options>Import (2) from the main menu.  After importing the 

options it is highly recommended that Vitesse be closed and restarted to ensure that all language changes take 

effect. 
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Version Information 
The Vitesse version being used can be found by selecting Help>About Vitesse from the main menu.  When 

asking questions about, or reporting problems with, Vitesse, please include the version number in your email. 

 

Updates 
When Vitesse is started, it will check if a new version has been released.  If so, the Update Available window 

will be displayed. 
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Interoperability 
Vitesse provides some operations for interoperating with other applications (timing systems, for example).  

Participants and start lists can be exported in a format that can be used by other applications.  Vitesse also 

provides a means for other applications to directly connect and get updates as a competition is created and 

modified. 

Note: The information in this section is of a more technical nature than the rest of this users guide. 

JSON Export 
JSON is a simple data interchange format that can be used by different applications to share data.  Vitesse can 

export both the participants list and race start lists in a JSON format.  Other applications (timing systems, for 

example) can then import the information from Vitesse.  To export the participants or start lists in JSON 

format, select File->Export->JSON from the main menu. 

 

Three export options are available 

Participants Exports all participant information.  Does not include any race information or start 
lists. 

Start Lists Exports race start lists.  Which start lists are exported can be filtered. 
All Includes all information from both the Participants and Start Lists exports in a single 

file. 
Details on the data contained in exported JSON files can be found in the Vitesse JSON Export Reference guide 

available on the Vitesse page at SpeedskatingResults.com (https://speedskatingresults.com/index.php?p=100). 
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Competition Server 
The Vitesse competition server can be enabled to allow other applications (e.g. timing systems) to directly 

connect to Vitesse.  Those applications will then automatically receive updates when a competition’s 

information (participants, races, start lists, etc.) is updated.  This removes the intermediate step of having to 

export the information in JSON format from Vitesse and import it into the other application. 

Technical details on the data available via the competition server can be found in the Vitesse JSON Export 

Reference guide available on the Vitesse page at SpeedskatingResults.com 

(https://speedskatingresults.com/index.php?p=100). 

 

To configure the server select Server->Settings from the main menu. 

 

Field Description 

Address The address clients should use to connect to the server 

Port The port to which clients should connect 

Enabled Enable or disable the server 

Clients List of clients connected to the server 

 

The Address and Port can only be changed when the server is disabled.  Connected clients can be forcibly 

disconnected by selecting their entry in the list, right clicking to bring up the context menu and then selecting 

Disconnect Client. 

Once the server has been configured, it may be quickly enabled and disabled by selecting Server->Enabled from 

the main menu. 

The server state can also be seen in the bottom right corner of the main Vitesse window. 
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The server button (1) shows the state of the server.  It will be green when the server is enabled and gray when 

it is disabled.  If enabled, the number of connected clients (2) will be displayed to the right of the button.   
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Right clicking on the server button (1) will allow access to the Competition Server settings window. 


